Stripe Issue: Unexpected error communicating with stripe

Stripe Announcement

Update (Jun 13, 2018): All requests made to Stripe servers using older versions of TLS are now blocked.

Update (Jan 31, 2018): We’ve announced our final deprecation timeline for older versions of TLS.

https://stripe.com/blog/upgrading-tls

Check if Your Website Supports TLS 1.2

  1. Installing https://www.dropbox.com/s/pucjlb07uljif1x/wilcity-check-tls2.zip?dl=0 plugin and Activate it
  2. Clicking on Pages -> New Page -> Put [wilcity_check_tls12] to the editor
  3. Clicking Publish -> View Page on the front-end, If you get the result looks like the following screenshot, which means your Website is supported TLS 1.2

How to upgrade from TLS 1.1 to TLS 1.2

  1. If you are using VPS, please read and follow https://support.stripe.com/questions/how-do-i-upgrade-my-openssl-to-support-tls-1-2
  2. Share Hosting: Please search for Google EG: If you are using GoDaddy, You can search for GoDaddy TLS 1.0 to 1.2, You will get https://vn.godaddy.com/community/GoDaddy-Web-Hosting/How-to-update-server-from-TLS-1-0-to-1-2/td-p/19223,  Or you can contact your hosting provider directly to ask for this.
Please follow and like us:
error
Tagged:

Leave A Comment?